This is a basic howto for the GuzziDiag suite of tools, for use on the CARC series, Breva
750, V7 Classic, & California 1100. This howto will show you how to connect, read (backup)
your existing map, write (flash) a new map and perform a TPS reset. This uses the Windows
versions as examples, but Mac & Linux versions function the same.

All types of ECU use the same version of GuzziDiag. Click on the link for your operating
system:

Windows: https://www.von-der-salierburg.de/download/GuzziDiag/GuzziDiag_V0.60.zip

Linux 32 bit: https://www.von-der-salierburg.de/download/GuzziDiag/GuzziDiag_V0.60_x86.t1gz
Linux 64 bit: https://www.von-der-salierburg.de/download/GuzziDiag/GuzziDiag_V0.60_x64.tgz
Mac: http.//www.griso.org/GuzziDiag_V0.46.app.zip

For the 5AM ECU, you will need the following Reader/Writer software from the GuzziDiag
page:

Windows:
http://www.von-der-salierburg.de/download/GuzziDiag/IAW5xReader_V0.28.zip
http://www.von-der-salierburg.de/download/GuzziDiag/IAWSxWriter_V0.24.zip
Linux 32 bit:
http://www.von-der-salierburg.de/download/GuzziDiag/IAW5xReader_V0.28.tgz
http://www.von-der-salierburg.de/download/GuzziDiag/IAW5xWriter_V0.24.tgz
Linux 64 bit:
http://www.von-der-salierburg.de/download/GuzziDiag/IAW5xReader_V0.28_x64.tgz
http://www.von-der-salierburg.de/download/GuzziDiag/IAWS5xWriter_V0.24_x64.tgz
Mac:
http://www.von-der-salierburg.de/download/GuzziDiag/IAW5xReader_V0.28_x64.app.zip
http://www.von-der-salierburg.de/download/GuzziDiag/IAW5xWriter_V0.24.app.zip


http://www.von-der-salierburg.de/download/GuzziDiag/IAW7SMReader_V0.03.zip

For the 15M/15P/15RC ECU
Windows:

http://www.von-der-salierburg.de/download/GuzziDiag/IAW15xReader _V0.68.zip

http://www.von-der-salierburg.de/download/GuzziDiag/IAW15xWriter V0.27.zip

Linux 32 bit:

http://www.von-der-salierburg.de/download/GuzziDiag/IAW15xReader V0.68.tgz

http://www.von-der-salierburg.de/download/GuzziDiag/IAW15xWriter_V0.27.tgz

Linux 64 bit:

http://www.von-der-salierburg.de/download/GuzziDiag/IAW15xReader V0.68 x64.tgz

http://www.von-der-salierburg.de/download/GuzziDiag/IAW15xWriter_V0.27 x64.tgz

Mac OS X:

http://www.von-der-salierburg.de/download/GuzziDiag/IAW15xReader _V0.67.app.zip

http://www.von-der-salierburg.de/download/GuzziDiag/IAW15xWriter _V0.26.app.zip

Each is a standalone program that works independently of each other and does not require any
extra software.

You will also need the two cables. They are available from various resellers on the
net. Lonelec is the best source on the net.

Get it here: https://www.lonelec.com/product/guzzidiag-jpdiag-ducatidiag-tuneecu-kit-
kl-1talia-3-pin-connection
You can also get the two on eBay and Amazon. You just need to ensure the USB cable has

the FTDI chip, otherwise it won't work

Do not use the drivers that come with the cables. Download these drivers:

Windows:

https://ftdichip.com/wp-content/uploads/2025/03/CDM-v2.12.36.20-WHQL-Certified.zip
OS X 10.9 & above: https://www.griso.org/FTDIUSBSerialDriver_v2_4_2.dmg

OS X 10.3 - 10.8: https://www.griso.org/FTDIUSBSerialDriver_v2_2_18.dmg

Linux doesn't require drivers.


http://www.von-der-salierburg.de/download/GuzziDiag/IAW15xReader_V0.67.zip
http://www.von-der-salierburg.de/download/GuzziDiag/IAW15xWriter_V0.26.zip
http://www.von-der-salierburg.de/download/GuzziDiag/IAW15xReader_V0.67.tgz
http://www.von-der-salierburg.de/download/GuzziDiag/IAW15xWriter_V0.26.tgz
http://www.von-der-salierburg.de/download/GuzziDiag/IAW15xReader_V0.67_x64.tgz
http://www.von-der-salierburg.de/download/GuzziDiag/IAW15xWriter_V0.26_x64.tgz
http://www.von-der-salierburg.de/download/GuzziDiag/IAW15xReader_V0.67.app.zip
http://www.von-der-salierburg.de/download/GuzziDiag/IAW15xWriter_V0.26.app.zip
https://www.obdinnovations.com/vag-kkl-obd2-usb-cable-ftdi-ft232rl-chip-fiat-3-pin-adapter-cable/
https://www.obdinnovations.com/vag-kkl-obd2-usb-cable-ftdi-ft232rl-chip-fiat-3-pin-adapter-cable/

Required Cables:

1. The OBD2 KKL 16 pin to USB cable with the FTDI chip. 2. The Fiat 3 Pin to 16 pin Adapter

3. The KL-1TALIA from Lonelec in the UK.



To connect to the bike, connect the two 16 pin connectors on the cables together and the 3 pin
cable to the diagnostic port. It's usually located under the seat beside the airbox or close to the
frame. For the Cali 1400, it's clipped to the ECU cover.

Attach the clips from the 3 pin cable to the battery (take note of polarity) and plug the USB
cable into a USB port on your computer.

A LED on the OBD2 cable will indicate power is connected.



To read and backup your existing map, open the Reader. Your computer may have multiple
COM ports, so select the correct one from the drop-down box. it is usually the last one or

highest number. if it doesn't connect at first, keep trying different ports. In my example, | only
have one, COM4.

B3 12w 5xReader V0.22 (m23m]

Then, click on 'read'

B3 12w 5x Reader V0.22 (m23m]

COM4 v




A dialog box will open, and here you can select the folder where you want to save the .bin file.
You can name it anything you like, but leave the "Save as type" as "*.bin".
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Click 'save'. You will then get:

o

B 1AW 5x Reader V0.22

Info

Switch ignition on.

Than press Ok.

Test-2604204.bin




Turn your keyswitch to 'on'. Do not start the engine. Click "OK". Reader will start downloading.
The download takes 15 minutes for CARC bikes, 20 minutes for Breva 750, V7 Classic & 1100
California.

B3 14w 5x Reader V0.22 ==

downloading... Test-2604204.bin

When it has finished, it will ask you to switch off your keyswitch.

B 1AW 5x Reader V0.22 [=]

Switch off ignition for
at least 10 seconds.

disconnected Test-2604204.bin

You have successfully saved your current map.



Writing a

To write or flash a new map, start the Writer program. You can select your COM port here as

well.

new map.

B 12w 5x Writer V0.20
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Click on the button with the 3 dots, and you will get a dialog box where you can browse to and
select the .bin file you wish to flash by clicking ‘Load'.
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Then, click 'Write' Note: In the bottom right-hand corner is the checksum of the bin file. If |
send you a map, it will have the checksum as part of the file name. If it is different, do not flash
it.

IAW 5x Writer V0.20 @
Gris0245-FU2-8A12.2014.04.24.bin ;

WLoad1039T 2014.04.26

5AM Checksum: 8A12

You will be asked to switch on your keyswitch again.

B 12w 5x Writer V0.20
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Info

Switch ignition on.

Than press Ok.

5AM Checksum: 8A12




It will start the upload. Note the message in the bottom left corner 'uploading'. Upload time is 3
minutes for CARC bikes, and 5 minutes for Breva 750, V7 Classic & 1100 California. The
message will then change to 'programming' as it writes the file to the ECU. Again, the use of a

battery tender is recommended.

It will confirm programming was successful.

A

&2

B 12w 5x Writer v0.20

Gris024S-FU2-8A12.2014.04.24 bin

Success @

Programming was successful!

disconnected 327680 5AM Checksum: 8A12

Click 'OK'" and switch off your keyswitch.

Here's a little video of a map upload: http://youtu.be/ZAi1N3ZFhHA



You will then need to reset your TPS (or relearn the throttle) and autolearning parameters.
Open the GuzziDiag program. Do NOT use GuzziDiag to reset the TPS on a Bellagio or
California 1100. For the Bellagio & 15M based 1100 California, the TPS is set via voltmeter and
is not required after a remap.

File View Help

ECU informations:

Griso 1200 8V Disconnected

Click 'File' -> 'Preferences' to configure the software. It only needs to be done once.

View Help

Connect

ECU informations:

IAW 5AM PF2C

Griso 1200 8V Disconnected




The GuzziDiag settings dialog box opens. Here you can select language, COM port and bike
type. Click the X to close, when done.
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File View Help

v Engine temperature v Advance ignition v

- Guzzi Diag Settings
w
Lambda mV 1 ~ [l injection periof | | 2n0uage: [English

‘ COM Port: [com

Motorcycle: [Griso 1200 8V

[ ECU informations:

Griso 1200 8V Disconnected

Next we want to connect to the ECU, so click 'File' -> 'Connect'

- GuzziDiag V0.36 (c) 2013 by Beard

(File] View Help

Engine temperature - Advance ignition - Status

Lambda mV 1 v Injection period v Air pressure v

[ ECU informations:

W

Griso 1200 8V Disconnected




It will ask you to switch on your keyswitch and click 'OK"

B GuzziDiag V0.36 (c) 2013 by Beard (=] = |[=]
File View Help

Engine temperature - Advance ignition - Status

Lanosa v - il mictonperod <500 un g (=]

Please switch on ignition.
Than press Ok.

ECU informations:

W

Griso 1200 8V Disconnected

You'll notice there are 8 drop down boxes to select various readouts. Select whatever you
wish. You should make sure one of the drop-downs selected is 'Throttle'.

‘ GuzziDiag V0.36 (c) 2013 by Beard
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Griso 1200 8V Disconnected




You can see here after uploading the map, my TPS (Throttle) is slightly out. It should read about
4.7. For CARC bikes, it could be 4.6, 4.7 or 4.8. For Breva 750 & V7 Classic, Throttle is 3.1. For
the 15RC California, spec is 3.2 - 3.6

B GuzziDiag V0.36 (c) 2013 by Beard ===
File View Help

Engine temperature Advance ignition
0 ooo [Engine off (02)
Side stand out

Lambda mV 1 Injection period Air pressure

Unknown 4 : 00

ECU informations:

Griso 1200 8V Connected

Let's reset it! Click on 'View' -> 'Actors'. You will see the 'Actors' menu.

Fuelpump Stepper (idle control) v

Ignition L

Griso 1200 8V Connected



Next, click on one of the drop-down selection boxes under 'Engine Off'

Stepper (idle control) -

Ignition L
Ignition R

Reset autolearning parameters
Service Reset (Ducati)

Ignition R v

Griso 1200 8V Connected

Select TPS Reset.

Stepper (idle control) v

Service Reset (Ducati)

Griso 1200 8V Connected -



Click 'Start'

TPS Reset - Stepper (idle control) v
— )

_

Griso 1200 8V Connected

You'll get the TPS Reset OK dialog. Click OK.



To reset the Autolearning parameters (ECU fuel trims), using the drop-down selection box,
select 'Reset autolearning parameters', then click 'Start'. Not required for 15M bikes.

Once you are done, click "File" -> "Disconnect"

-GuzziDiag V0.36 (c) 2013 by Beard (o] @ ][=]
File View Help

Lambda mV 1 v

Griso 1200 8V Disconnected




CO Trim - 5AM & 15M/15RC only.

If you load a new map or do something simple to your stock map like switch of the lambda
sensor, you may find you need to adjust the CO trim for a smoother idle or less smelly idle (too
much fuel). You should only do this after a test ride or if you have a rough idle. For example, the
8V idles at 1200 +/- 50, 2V 1100 at 1100 +/- 100. If your idle is low, or very lumpy, you may
need to go positive. If your idle is high, you may need to go positive or negative. If you smell
unburnt fuel, you should go negative.

To do this with GuzzDiag, get your engine up to temperature (which is 60 deg celsius). Go for a
short ride or let it idle with GuzziDiag connected so you can monitor the engine temp.

= GuzziDiag V0.39 (c) 2013 by Beard - + %

File View Help

CO Trimm Air pressure

Griso 1200 8V | Connected ||




Once up to 60C, hit the kill switch. Click on 'View' -> 'CO Trim'

o] GuzziDiag V0.39 (c) 2013 by Beard
File Help
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Griso 1200 8V ~ Connected

You will get the following dialog box. Click 'OK'

| GuzziDiag V0.39 (c) 2013 by Beard
File View Help

The engine has to be off!

~/hOK

Griso 12008V || Connected




You will then be presented with the CO trim menu. Click 'Start'

e GuzziDiag V0.39 (c) 2013 by Beard - + %

File View Help

Griso 1200 8V Connected

You will get a dialog box that asks you to start your engine. Click 'Ok’ and start 'er up.

| GuzziDiag V0.39 (c) 2013 by Beard - 4+ %

File View Help

Gentleman, please start your engine!

v OK
L3

Griso 12008V || Connected ||




With the engine running, click the plus '+' or 'minus '-' button to adjust the CO trim. You can go
up to +128 or down to -128. Every +/-1 step adds or removes 100uS to the injection pulse. The
entire rev range is affected, although the greatest affect is at idle. The effect is non-linear.
Adjusting CO too far will affect the midrange and top end.

What value you use will depend on what type of map you have installed and what you are
trying to achieve. If you have one of my maps built specifically for the exhaust you have, you
should only need to go +/- a small amount. If you smell unburnt fuel, try going to -5. Wait 15-20
seconds. Click 'Finish'. Let it idle for a few seconds. Better or worse? Go up or down as
needed. With each change, make sure you wait ~20 seconds between adjustments, and be
sure to click 'Finish'. If you have a rough or lumpy idle, try going positive first. Say, +3 or +5.
Better or worse? Go up or down as needed. If you have to go more than 10 in either direction,
you have the wrong map, you have a mechanical issue you should address, or may have
forgotten to reset the TPS or relearn the throttle.

When you click 'Start' to make another adjustment, GuzziDiag will ask you start your engine
again, but as it is already running, simply click 'OK' and go. Repeat as necessary until idle is
smooth and at your required idle RPM. Always make sure you hit the 'Finish' button when
you've made a change. Once done, hit the kill switch.

Try not to let the engine get too hot. You can't hurt anything by adjusting the CO trim, unless
you set the number too negative, in which case the engine may run lean. If you feel you haven't
quite got it right, let the engine cool off and start again. Of course, you can use a fan to assist
with cooling.
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Donel!






